Library Website Experiencing Issues

Incident Report for UCSB Library

Resolved

This incident has been resolved.
Posted Jun 08, 2025 - 17:52 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 08, 2025 - 17:43 PDT

Identified

We have identified an issue with the CSS not loading on the homepage and are currently working on a resolution.
Posted Jun 08, 2025 - 16:39 PDT

Investigating

We are currently investigating an issue with the library's main website homepage.
Posted Jun 08, 2025 - 16:27 PDT
This incident affected: Library Website.