503 error when accessing images

Incident Report for UCSB Library

Resolved

as of 12:12pm pacific time we have resolved this issue.
We'll continue to monitor for the next few hours to ensure the changes made fully address the issue.
Posted Nov 19, 2025 - 12:26 PST

Investigating

We are currently investigating a 503 error when trying to access aerial photograph images via FrameFinder.
Posted Nov 17, 2025 - 11:45 PST
This incident affected: Map and Imagery (Frame Finder).