FrameFinder Download Issue

Incident Report for UCSB Library

Resolved

This incident has been resolved.
Posted Mar 25, 2026 - 12:47 PDT

Investigating

We are currently investigating an issue that results in a 503 error when attempting to download an image.
Posted Mar 25, 2026 - 09:31 PDT
This incident affected: Map and Imagery (Frame Finder).