Library Storage Outage
Incident Report for UCSB Library
Resolved
The ITS Infrastructure unit has stabilized the system, and shares have remained available since 4/19. However, the equipment is near the end of its viability, and therefore efforts are ongoing to transition data to a more resilient structure. More information will be provided.

This incident is now considered resolved.
Posted Apr 29, 2024 - 13:49 PDT
Monitoring
We have continued efforts to stabilize the storage situation with the Library NetApp. We anticipate that most shares will remain online as we work on a parallel effort to move the affected shares. All shares remain available.
Posted Apr 18, 2024 - 17:09 PDT
Update
Overnight we received alerts that the library NetApp and the shares are unavailable. IT is investigating.
Posted Apr 17, 2024 - 07:20 PDT
Update
The work on 2024-04-15 to replace the failed controller was generally a success. During the effort, additional drives failed, which affected a single file share (that had been migrated to AWS and is slated for decommission). We are waiting for the next steps from NetApp to bring the failed drives back online.
Posted Apr 16, 2024 - 10:45 PDT
Update
From 5PM on Saturday 2024-04-13, the our support field engineers and the ITS Infrastructure team will conduct the replacement of the failed controller on the NetApp storage appliance. The maintenance will take several hours to complete, and there may be intermittent outages to the previously outlined services during this process.
Posted Apr 12, 2024 - 16:27 PDT
Update
At this time, most services have been restored, however performance is still degraded due to the hardware appliance performing consistency checks. Additionally, plans are being drawn up to replace a failed controller and more information will be shared as it is available.
Posted Apr 11, 2024 - 09:37 PDT
Update
We continue to experience degraded services for the items previously identified. ITS is working to continue troubleshooting the issue, and the support vendor has been updated. Replacement hardware is due to be delivered this morning.
Posted Apr 09, 2024 - 08:12 PDT
Update
There are additional issues that have been identified with the Library storage system. We continue to experience degraded services for the items previously identified. ITS is working to continue troubleshooting the issue, and the support vendor has been updated.
Posted Apr 08, 2024 - 21:13 PDT
Identified
The issue has been identified. Services are starting to be restored; however, the storage is still in a degraded state. IT is continuing to work on the issue.
Posted Apr 08, 2024 - 11:11 PDT
Investigating
ITS has been working on an incident for library storage which is impacting multiple services including, but not limited to:

Various file shares in svmwindows.library.ucsb.edu and library\dfsroot
Public Machines
adp.library.ucsb.edu
victorledgers.library.ucsb.edu
cemaweb.library.ucsb.edu

ITS is engaged with support venders to help resolve the storage issues.
Posted Apr 08, 2024 - 10:11 PDT
This incident affected: Discography of American Historical Recordings (American Discography Project (ADP)), Aerial Photography Catalog, File Shares (SVMWINDOWS Shares), and Library Core Infrastructure and Internal Services (NetApp Storage Array).