ADRL: Images and file downloads not available

Incident Report for UCSB Library

Resolved

The issue was determined to be a volume that failed to mount. This incident has been resolved.
Posted Mar 06, 2025 - 14:15 PST

Investigating

We have confirmed reports of errors when attempting to download files and access images. We are currently investigating the issue.
Posted Mar 06, 2025 - 12:42 PST
This incident affected: Alexandria Digital Research Library.